him1974 15 июля 2015 0 0
Залил сайт на хостинг, все заработало и сайт и админка. Установил визуальный редактор TinyMCE 4.3.3. При замене картинки ничего не происходит. Мало того, остальные картинки на странице скрываются, слайдер из картинок «упал». Восстановил сайт с нуля, снова поставил редактор, попробовал вставить маленькую картинку — та же ситуация — пропадают другие изображения на странице. Чистил кеш сайта, что еще сделать или проверить?
0 комментариев
Tramp13571
Tramp1357 15 июля 2015г в 16:14 #
Я стараюсь вообще визуальный редактор не ставить — для контента достаточно научить людей паре тегов :)
Но если необходимо — ставлю CKEditor. Он как-то постабильнее, и при переносе из того же word или excel более аккуратно с разметкой себя ведет.
h
him1974 15 июля 2015г в 16:15 #
Спасибо, попробую поставить… Локально под денвером все работает на Ура, а вот на хостинге не хочет…
h
him1974 15 июля 2015г в 16:27 #
Не работает, поставил редактор, меняю картинку на другую, в админке меняется, на сайте остается прежняя. Обновлял кеш, что то не хочет… Может дело в правах на папки или еще чего?
Tramp13571
Tramp1357 15 июля 2015г в 16:37 #
вот тут уже не подскажу. Посмотри в журнале ошибок — может, там есть что
h
him1974 15 июля 2015г в 16:45 #
Нашел в чем дело. Оказывается редактор вырезал СЛЭШ. Вот пример как должно быть и картинку видно
<div class="svu-1-content"><img src="/static/images/tech/svu-1.png"/><img height="240" src="/static/images/tech/svu-2.png" width="317"/>
И Что он сделал и картинку не видно
<div class="svu-1-content"><img src="/static/images/tech/svu-1.png"/><img height="240" src="/static/images/tech/svu-2.png" width="317"/>
static во втором случае, в конце начался без слеша. Как так?:) Поставил и все появилось
Авторизуйтесь или зарегистрируйтесь (можно через соцсети ), чтобы оставлять комментарии.