glazunoff 02 октября 2015 0 3
Добрый день, господа.
Подскажите, пожалуйста, в чем может быть проблема. Сайт на Modx Evo. После установки конфигурации на сервер:
allow_url_fopen = Off
allow_url_include = Off
expose_php = Off
magic_quotes_gpc = On
register_globals = Off
disable_functions = popen,exec,system,passthru,proc_open,shell_exec,ini_restore,dl,symlink,chgrp,ini_set,putenv,getmyuid,fsockopen,posix_setuid,posix_setsid,posix_setpgid,posix_kill,apache_child_terminate,chmod,chdir,pcntl_exec,phpinfo,virtual,proc_close,proc_get_status,proc_terminate,proc_nice,getmygid,proc_getstatus,proc_close,escapeshellcmd,escapeshellarg,show_source,pclose,safe_dir,dl,ini_restore,chown,chgrp,shown_source,mysql_list_dbs,get_current_user,getmyid,leak,pfsockopen,get_current_user, extension_loaded,syslog
safe_mode = On
safe_mode_gid = On

Стали появляться битые ссылки и теги — автоматически. Редактируешь, правишь статью — сохраняешь и все теги становятся битыми.
Пример: ссылка (смотреть в тело статьи)
Везде добавляются: \

Надеюсь на помощь.
Спасибо.
3 комментария
Fi1osof1
Fi1osof 02 октября 2015г в 16:26 #
Так у вас magic_quotes_gpc = On, что же вы хотите? Вы серверу сказали «обрабатывай все передаваемые данные и экранируй все кавычки и обратные слешы», и удивляетесь тому, что он это самое и делает.
g
glazunoff 02 октября 2015г в 16:40 #
Спасибо, Николай. Просто один товарищ утверждал, что дело не в конфигурации.
А я в этом не профессионал.
Еще раз спасибо!
Fi1osof1
Fi1osof 03 октября 2015г в 13:47 #
Пожалуйста!
Авторизуйтесь или зарегистрируйтесь (можно через соцсети ), чтобы оставлять комментарии.