burick 23 апреля 2013 0 10
Господа хелп!
Во столкнулся с такой штукой, не могу изменить настройки системы: Все заблокировано. и дерево ресурсов-элементов-файлов на вкладке «Настройки системы» тоже заблокировано, пощелкал по менюшкам на первый взгляд все остальное работает и дерево ресурсов-элементов-файлов на других вкладках открывается.
Вопрос собственно почему и как? Как разблокировать и вероятная причина блокировки.
З.Ы. Журнал ошибок чистый как постель девственницы.
10 комментариев
Fi1osof1
Fi1osof 24 апреля 2013г в 02:50 #
Тут так сразу не скажешь. Ни разу с этим не сталкивался. Но попробуйте простой финт — сделайте пользователя sudo. Для него никакие ограничения политик безопасности не будут иметь значения. Если проблема решится — значит все дело в настройках политик. Если не решится, то скорее всего или JS-ошибки, или какой-то кривой пакет инсталлирован.
abaddon651
abaddon65 24 апреля 2013г в 10:24 #
А прям так и написано, что заблокировано или просто не показывается? У меня второй вариант был, решил отключением компрессии js — са админки.
burick1
burick 24 апреля 2013г в 13:59 #
Собственно вот картинки...
Консоль браузера не показывает никаких JS ошибок.
burick1
burick 24 апреля 2013г в 19:11 #
Кстати вот еще на вкладке «Панель» тоже дерево и панель «Недавно редактированные ресурсы» тоже пишет заблокировано… Может напрямую через базу можно как то разблокировать?
Fi1osof1
Fi1osof 25 апреля 2013г в 00:53 #
Давайте называть вещи своими именами, мы же специалисты. Он не пишет «заблокировано», он пишет «Доступ закрыт». 100% где-то вклинились в механизм. Вам коннектор говорит «Вам нет доступа». Скорее всего switchContext выполняется или еще что-то. Или обновляли версию движка и не корректно. На более новых версиях MODX-а механизм проверки прав в коннекторах менялся.
Создайте чистый сайт, снимите с этого Vapor-ом снимок и накатите туда. Или сделайте копию сайта и выполните полное обновление движка. Должно помочь. Просто что-то зацепили.
P.S. На всякий случай еще деактивируйте все включенные плагины.
burick1
burick 27 апреля 2013г в 13:21 #
Вот какая странная хрень получается, в ФФ нормально все работает, а Хром доступ закрыт, кеш и куки чистил ССleaner-ом, и это при том что на других сайтах нормально и в хроме и везде… Чет у меня в голове не складывается как так.
burick1
burick 27 апреля 2013г в 14:10 #
В общем я в Хром победил тотальным уничтожением папки «Local Settings\Application Data\Google\Chrome\User Data\»
Подозреваю что все это связано с локальным хранилищем
Fi1osof1
Fi1osof 27 апреля 2013г в 16:25 #
Ааа, про хром имело смысл сразу уточнить :) В MODX такая экспериментальная фигня есть — поддержка HTML5. Она использует хранение данных в хранилище браузера, и у хрома свое хитрое хранилище. В настройках даже такое есть: manager_html5_cache (проверь, не включена ли? Хотя она по умолчанию обычно отключена, и нет гарантии, что сейчас проблема именно в этом, но тем не менее).
burick1
burick 27 апреля 2013г в 19:12 #
Да кто ж знал, у каждого свои грабли, manager_html5_cache сейчас отключен, Я его как то включал, смотрел чо за зверь такой, потом отключил, а вот побочка вылезла позже, я поэтому и написал что думаю что с локальным хранилищем связано
Fi1osof1
Fi1osof 27 апреля 2013г в 19:18 #
Да, эта штука тем и противна, что может проявиться уже и после отключения.
Авторизуйтесь или зарегистрируйтесь (можно через соцсети ), чтобы оставлять комментарии.