vincity.info 03 января 2017 6 1
Доброго времени суток.
Столкнулся с такой проблемой.
На локалке установлен modx 2.5.2 установил последнюю версию modxsdk захожу в приложения modxsdk и вижу пустую страницу. Дерево документов есть все есть только на месте sdk пусто.
Версия php 7.0 менял на 5.6 все без изменений.
Как можно решить данную проблему?
Sardakar 30 января 2016 1 9
Здравствуйте.

Суть проблемы: делал сайт на локальном сервер (Operserver), по не знанию (впервые знакомился с modx revo) ставил покеты в ручную (ace, console, getpage, modxsdk, modxsite, modxsmarty, phptemplates). По окончании работ настал момент переноса сайта на тестовый сервер в интернете.
Осуществлял перенос с помощью Vapor (ставил чистый modx revo 2.4.2) и устанавливал полученный пакет.

Все перенеслось без ошибок, единственная проблема при редактировании файлов через modxSDK данные сохраняются, но на сайте изменения не отображаются и если зайти по фтп и открыть этот же файл, то изменений не наблюдается. Причем если редактирует другой человек из другого города, то я вижу его изменения через SDK.

Была версия что сохраняются файлы по другому пути, но поиск по содержимому в файлах сайта и в базе также ничего не дал.

Ставил также чистый modx revo (2.4.2 и 2.3.6) на этот же сервер и пакет shopmodxbox на этот же сервер. Такой проблемы в этом случае не наблюдалось.

Поиск решений схожих проблем ничего не дал. Подскажите, если есть какие идеи.

Заранее спасибо.
sanch0ss 24 августа 2015 0 6
Добры день!
Вопрос к вашему видео
Компоне(?)т modxSite для MODX Revolution.

Не уходит эта ошибка… tpl файл создаю, папки… Делаю по видео всё
Fatal error: Uncaught --> Smarty: Unable to load template file 'tpl/index.tpl' < — thrown in Z:\home\e\www\core\components\modxsmarty\external\smarty\libs\sysplugins\smarty_internal_template.php on line 212

Скрин папок и шаблона tpl

В чем может быть дело?
modx 2.3.3
за почти два года может быть инструкция уже устарела?
poltoraivana_ru 15 марта 2015 0 19
Кто-нибудь может мне сказать поддерживается ли ModxSDK в Modx версии 2.3.2 или 2.3.3
Читал что перед новым годом довели до ума, но у меня по прежнему не работает ModxSDK
Пытаюсь перейти по ссылке в админке и выбрасывает пустой экран — я так понял что ещё не готово!
Прошу уточнить!!!
firstgm 24 февраля 2015 3 7
Здравствуйте!
Прошу подсказать, как правильно подключить нужный шаблон в Smarty используя условие.

Есть форма с полем ввода «Серия», если в это поле введено «CM» нужно вывести ответ в другом шаблоне (с другим дизайном).

{if $request.serial == 'CM'}
    {extends "layout2.tpl"}
    {else}
    {extends "layout.tpl"}
{/if}


Предполагаю, что это не совсем сложно, но и не так просто, как я написал вышел в примере… Однако в синтаксисе Smarty я пока новичок.
mong 20 сентября 2014 0 6
Здравствуйте!
Когда запускаю modxSDK выскакивает вот это:
Fatal error: require_once(): Failed opening required '/home/plab-mong/web/vain.stark1.ru/public_html/core/components/modxsdk/controllers/index.class.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/plab-mong/web/vain.stark1.ru/public_html/core/model/modx/modmanagercontroller.class.php on line 935

я пока не сильно в php понимаю, если не затруднит расскажите по подробней, из-за чего это? и как можно исправить.
p.s установка чистая, версия 2.3.1 допы modxSite и modxSDK установились нормально.